GitHub Advisoryadvisory · Packagist
GHSA-3fr3-gcqh-3m2g Magento Open Source Improper Input Validation vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-45117
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L
- Weaknesses
- CWE-20
- Reviewed
- 2024-10-11
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p3 → fixed in 2.4.7-p3
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p8 → fixed in 2.4.6-p8
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p10 → fixed in 2.4.5-p10
• Packagist magento/community-edition: < 2.4.4-p11 → fixed in 2.4.4-p11
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
Description
Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An admin attacker could exploit this vulnerability to read files from the system outside of the intended directories via PHP filter chain and also can have a low-availability impact on the service. Exploitation of this issue does not require user interaction and scope is changed.
Related
Alias · CVE (1)
- CVE-2024-45117 Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness