GitHub Advisoryadvisory · Go
GHSA-3g36-gf7c-75qw Mattermost Playbooks fails to properly validate the props used by the RetrospectivePost custom post type
MEDIUM
Official page ↗
- Aliases
- CVE-2025-41395
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-plugin-playbooks, github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1287
- Reviewed
- 2025-04-24
Affected packages
• Go github.com/mattermost/mattermost-plugin-playbooks: < 2.1.1 (no fix yet)
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250218121836-2b5275d87136 → fixed in 8.0.0-20250218121836-2b5275d87136
• Go github.com/mattermost/mattermost/server/v8: < 10.4.3 (no fix yet)
• Go github.com/mattermost/mattermost/server/v8: < 10.5.1 (no fix yet)
• Go github.com/mattermost/mattermost/server/v8: < 9.11.11 (no fix yet)
• Go github.com/mattermost/mattermost-plugin-playbooks: < 1.41.0 → fixed in 1.41.0
Description
Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate the props used by the RetrospectivePost custom post type in the Playbooks plugin, which allows an attacker to create a specially crafted post with maliciously crafted props and cause a denial of service (DoS) of the web app for all users.
Related
Alias · CVE (1)
- CVE-2025-41395 Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate the props used by the RetrospectivePost… vulnerability
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-41395 advisory
- https://github.com/mattermost/mattermost-plugin-playbooks/commit/4c823090e281cb9c0d5c17ee2e5db275117540d1 web
- https://github.com/mattermost/mattermost/commit/2b5275d87136f07e016c8eca09a2f004b31afc8a web
- https://github.com/mattermost/mattermost-plugin-playbooks package
- https://mattermost.com/security-updates web