GitHub Advisoryadvisory · Packagist

GHSA-3g7m-g8qm-x6j5 Magento discloses sensitive information

MEDIUM Published 2022-05-24 Modified 2025-11-07 Official page ↗
Aliases
CVE-2021-36039
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-863
Reviewed
2025-11-07

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1 • Packagist magento/community-edition: 2.3.7 (no fix yet) • Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2 • Packagist magento/community-edition: 2.4.2 (no fix yet)

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability via the `quoteId` parameter. An attacker can abuse this vulnerability to disclose sensitive information.

Related

Alias · CVE (1)

  • CVE-2021-36039 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References