GitHub Advisoryadvisory · Go
GHSA-3gfj-fxx4-f22w OpenFGA Authorization Bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2022-39352
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-11-08
Affected packages
• Go github.com/openfga/openfga: < 0.2.5 → fixed in 0.2.5
Description
Overview
During our internal security assessment, it was discovered that OpenFGA versions v0.2.4 and prior are vulnerable to authorization bypass under certain conditions.
Am I Affected?
You are affected by this vulnerability if you are using `openfga/openfga` version v0.2.4 or prior, and have tuples where the `user` field is set to a `userset` e.g. `folder:test#owner`, and the tuple's relation is used on the right-hand side of a `from` statement.
How to fix that?
Upgrade to version 0.2.5.
Backward Compatibility
This update is not backward compatible.
Any tuples where the `user` field is set to a `userset`, and the tuple's relation is used on the right-hand side of a `from` statement have to be rewritten.
Related
Alias · CVE (1)
- CVE-2022-39352 OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/openfga/openfga/security/advisories/GHSA-3gfj-fxx4-f22w web
- https://nvd.nist.gov/vuln/detail/CVE-2022-39352 advisory
- https://github.com/openfga/openfga/commit/776e80505e8d184b2286acc8268d8d74f36a9984 web
- https://github.com/openfga/openfga package
- https://github.com/openfga/openfga/releases/tag/v0.2.5 web