GitHub Advisoryadvisory · npm

GHSA-3gvp-54v2-2jrp Directus API vulnerable to denial of service

MEDIUM Published 2023-04-04 Modified 2023-04-07 Official page ↗
Aliases
CVE-2020-19850
Ecosystem
npm
Packages
directus
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2023-04-07

Affected packages

• npm directus: >= 2.2.0, < 2.2.1 → fixed in 2.2.1

Description

An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests.

Related

Alias · CVE (1)

  • CVE-2020-19850 An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References