GitHub Advisoryadvisory · Packagist

GHSA-3gx6-h57h-rm27 Drupal Core Remote Code Execution Vulnerability

HIGH Published 2022-05-13 Modified 2025-10-22 Official page ↗
Aliases
CVE-2019-6340
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-502
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 8.6.0, < 8.6.10 → fixed in 8.6.10 • Packagist drupal/core: >= 7.0.0, < 7.62.0 → fixed in 7.62.0 • Packagist drupal/core: >= 8.0.0, < 8.5.11 → fixed in 8.5.11 • Packagist drupal/drupal: >= 7.0.0, < 7.62.0 → fixed in 7.62.0 • Packagist drupal/drupal: >= 8.0.0, < 8.5.11 → fixed in 8.5.11 • Packagist drupal/drupal: >= 8.6.0, < 8.6.10 → fixed in 8.6.10

Description

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Related

Alias · CVE (1)

  • CVE-2019-6340 Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References