GitHub Advisoryadvisory · npm
GHSA-3gx7-xhv7-5mx3 Arbitrary Code Execution in eslint-utils
CRITICAL
Official page ↗
- Aliases
- CVE-2019-15657
- Ecosystem
- npm
- Packages
- eslint-utils
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• npm eslint-utils: >= 1.2.0, < 1.4.1 → fixed in 1.4.1
Description
Versions of `eslint-utils` >=1.2.0 or <1.4.1 are vulnerable to Arbitrary Code Execution. The `getStaticValue` does not properly sanitize user input allowing attackers to supply malicious input that executes arbitrary code during the linting process. The `getStringIfConstant` and `getPropertyName` functions are not affected.
Recommendation
Upgrade to version 1.4.1 or later.
Related
Alias · CVE (1)
- CVE-2019-15657 In eslint-utils before 1.4.1, the getStaticValue function can execute arbitrary code. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/mysticatea/eslint-utils/security/advisories/GHSA-3gx7-xhv7-5mx3 web
- https://nvd.nist.gov/vuln/detail/CVE-2019-15657 advisory
- https://github.com/mysticatea/eslint-utils/commit/08158db1c98fd71cf0f32ddefbc147e2620e724c web
- https://eslint.org/blog/2019/08/eslint-v6.2.1-released web
- https://github.com/advisories/GHSA-3gx7-xhv7-5mx3 advisory
- https://github.com/mysticatea/eslint-utils package
- https://www.npmjs.com/advisories/1118 web