GitHub Advisoryadvisory · RubyGems

GHSA-3h4r-pjv6-cph9 RubyGems Escape sequence injection vulnerability in api response handling

HIGH Published 2019-06-20 Modified 2023-08-28 Official page ↗
Aliases
CVE-2019-8323
Ecosystem
RubyGems
Packages
rubygems-update
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-74
Reviewed
2019-06-20

Affected packages

• RubyGems rubygems-update: >= 2.6.0, < 2.7.9 → fixed in 2.7.9 • RubyGems rubygems-update: >= 3.0.0, < 3.0.2 → fixed in 3.0.2

Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.

Related

Alias · CVE (1)

  • CVE-2019-8323 An issue was discovered in RubyGems 2.6 and later through 3.0.2. vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References