GitHub Advisoryadvisory · RubyGems

GHSA-3h7v-wqw7-ff28 Cross site scripting in publify

MEDIUM Published 2022-05-24 Modified 2022-06-03 Official page ↗
Aliases
CVE-2021-25975
Ecosystem
RubyGems
Packages
publify_core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-06-03

Affected packages

• RubyGems publify_core: >= 8.0, < 9.2.5 → fixed in 9.2.5

Description

In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. This issue allows a user with “publisher” role to inject malicious JavaScript via the uploaded html file.

Related

Alias · CVE (1)

  • CVE-2021-25975 In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References