GitHub Advisoryadvisory · PyPI
GHSA-3hj6-r5c9-q8f3 Frappe has possibility of SQL injection due to improper validations
MEDIUM
Official page ↗
- Aliases
- CVE-2025-30212
- Ecosystem
- PyPI
- Packages
- frappe
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-89
- Reviewed
- 2025-03-25
Affected packages
• PyPI frappe: < 14.89.0 → fixed in 14.89.0
• PyPI frappe: >= 15.0.0, < 15.51.0 → fixed in 15.51.0
Description
Impact
An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information.
Workarounds
Upgrading is required, no other workaround is present.
Credits
Thanks to Thanh of Calif.io for reporting the issue
Related
Alias · CVE (1)
- CVE-2025-30212 Frappe is a full-stack web application framework. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/frappe/frappe/security/advisories/GHSA-3hj6-r5c9-q8f3 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-30212 advisory
- https://github.com/frappe/frappe/commit/27f13437db161a173137d91cd07d0f9287d7c556 web
- https://github.com/frappe/frappe/commit/2ebd88520ecfa9bb7d3392b7de8c8f94a86ec05c web
- https://github.com/frappe/frappe package