GitHub Advisoryadvisory · npm

GHSA-3hjg-vc7r-rcrw Denial of Service vulnerability in @podium/layout and @podium/proxy

HIGH Published 2022-04-07 Modified 2022-04-07 Official page ↗
Aliases
CVE-2022-24822
Ecosystem
npm
Packages
@podium/layout, @podium/proxy
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-248
Reviewed
2022-04-07

Affected packages

• npm @podium/layout: < 4.6.110 → fixed in 4.6.110 • npm @podium/proxy: < 4.2.74 → fixed in 4.2.74

Description

Impact An attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. Patches `@podium/layout` which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable. `@podium/proxy` which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. Workarounds It is not easily possible to work around this issue without upgrading. We recommend upgrading `@podium/layout` and/or `@podium/proxy` as soon as possible. For more information If you have any questions or comments about this advisory: • Open an issue in podium-lib/issues Credits The vulnerability was reported by krynos from Ercoli Consulting via FINN.no's private bug bounty program

Related

Alias · CVE (1)

  • CVE-2022-24822 Podium is a library for building micro frontends. vulnerability

Weakness · CWE (1)

  • CWE-248 Uncaught Exception weakness

References