GitHub Advisoryadvisory · Maven
GHSA-3hvc-xwjp-xr8m Liquibase Runner Plugin allows users to load arbitrary Java code into controller JVM
HIGH
Official page ↗
- Aliases
- CVE-2018-1000146
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:liquibase-runner
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2023-12-15
Affected packages
• Maven org.jenkins-ci.plugins:liquibase-runner: < 1.4.3 → fixed in 1.4.3
Description
An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0 and older that allows an attacker with permission to configure jobs to load and execute arbitrary code on the Jenkins master JVM.
Related
Alias · CVE (1)
- CVE-2018-1000146 An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0 and older that allows an attacker with permission… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000146 advisory
- https://github.com/jenkinsci/liquibase-runner-plugin/commit/1817af0b5bb17e690d89c0a1623de8bd47f8c1a1 web
- https://github.com/jenkinsci/liquibase-runner-plugin/commit/382a1ea84910db28a88089306b24d1e80818f0a5 web
- https://github.com/jenkinsci/liquibase-runner-plugin/commit/7726ce4569a287e32fbda6f01ad2846ada909436 web
- https://github.com/jenkinsci/liquibase-runner-plugin web
- https://jenkins.io/security/advisory/2018-03-26/#SECURITY-519 web