GitHub Advisoryadvisory · Maven

GHSA-3hwc-rqwp-v36q Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies

HIGH Published 2024-02-09 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-50291
Ecosystem
Maven
Packages
org.apache.solr:solr-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-522
Reviewed
2024-02-09

Affected packages

• Maven org.apache.solr:solr-core: >= 6.0.0, < 8.11.3 → fixed in 8.11.3 • Maven org.apache.solr:solr-core: >= 9.0.0, < 9.3.0 → fixed in 9.3.0

Description

Insufficiently Protected Credentials vulnerability in Apache Solr. This issue affects Apache Solr from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI. This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue. A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps". By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password". Users who cannot upgrade can also use the following Java system property to fix the issue:   `-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*`

Related

Alias · CVE (1)

  • CVE-2023-50291 Insufficiently Protected Credentials vulnerability in Apache Solr. vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References