GitHub Advisoryadvisory · Maven

GHSA-3j6g-hxx5-3q26 Observable Discrepancy in Apache Kafka

MEDIUM Published 2021-09-23 Modified 2022-02-08 Official page ↗
Aliases
CVE-2021-38153
Ecosystem
Maven
Packages
org.apache.kafka:kafka_2.11, org.apache.kafka:kafka_2.12, org.apache.kafka:kafka_2.13, org.apache.kafka:kafka-clients
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-203
Reviewed
2021-09-23

Affected packages

• Maven org.apache.kafka:kafka_2.11: >= 2.0.0, <= 2.4.1 (no fix yet) • Maven org.apache.kafka:kafka_2.12: >= 2.0.0, < 2.6.3 → fixed in 2.6.3 • Maven org.apache.kafka:kafka_2.12: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • Maven org.apache.kafka:kafka_2.12: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • Maven org.apache.kafka:kafka_2.13: >= 2.4.0, < 2.6.3 → fixed in 2.6.3 • Maven org.apache.kafka:kafka_2.13: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • Maven org.apache.kafka:kafka_2.13: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • Maven org.apache.kafka:kafka-clients: >= 2.0.0, < 2.6.3 → fixed in 2.6.3 • Maven org.apache.kafka:kafka-clients: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • Maven org.apache.kafka:kafka-clients: >= 2.8.0, < 2.8.1 → fixed in 2.8.1

Description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Related

Alias · CVE (1)

  • CVE-2021-38153 Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute… vulnerability

Weakness · CWE (1)

  • CWE-203 Observable Discrepancy weakness

References