GitHub Advisoryadvisory · Packagist
GHSA-3j7w-jp46-9752 Magento Open Source allows Cross-Site Scripting (XSS)
LOW
Official page ↗
- Aliases
- CVE-2023-38219
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-beta2 → fixed in 2.4.7-beta2
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p3 → fixed in 2.4.6-p3
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p5 → fixed in 2.4.5-p5
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p6 → fixed in 2.4.4-p6
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Payload is stored in an admin area, resulting in high confidentiality and integrity impact.
Related
Alias · CVE (1)
- CVE-2023-38219 Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness