GitHub Advisoryadvisory · PyPI
GHSA-3j8r-jf9w-5cmh LlamaIndex vulnerability in its ObsidianReader class can lead to Path Traversal exploit
MEDIUM
Official page ↗
- Aliases
- CVE-2025-6210
- Ecosystem
- PyPI
- Packages
- llama-index-readers-obsidian
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2025-07-08
Affected packages
• PyPI llama-index-readers-obsidian: < 0.5.2 → fixed in 0.5.2
Description
A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, before version 0.5.2 (specifically in version 0.12.27 of llama-index), allows for hardlink-based path traversal. This flaw permits attackers to bypass path restrictions and access sensitive system files, such as /etc/passwd, by exploiting hardlinks. The vulnerability arises from inadequate handling of hardlinks in the load_data() method, where the security checks fail to differentiate between real files and hardlinks. This issue is resolved in llama-index-readers-obsidian version 0.5.2.
Related
Alias · CVE (1)
- CVE-2025-6210 A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness