GitHub Advisoryadvisory · Packagist

GHSA-3m36-mjwj-352c Drupal core Cross-site Scripting (XSS) vulnerability

MEDIUM Published 2022-02-12 Modified 2024-05-15 Official page ↗
Aliases
CVE-2020-13672
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-15

Affected packages

• Packagist drupal/core: >= 7.0.0, < 7.80 → fixed in 7.80 • Packagist drupal/core: >= 8.0.0, < 8.9.14 → fixed in 8.9.14 • Packagist drupal/core: >= 9.0.0, < 9.0.12 → fixed in 9.0.12 • Packagist drupal/core: >= 9.1.0, < 9.1.7 → fixed in 9.1.7 • Packagist drupal/drupal: >= 7.0.0, < 7.80 → fixed in 7.80 • Packagist drupal/drupal: >= 8.0.0, < 8.9.14 → fixed in 8.9.14 • Packagist drupal/drupal: >= 9.0.0, < 9.0.12 → fixed in 9.0.12 • Packagist drupal/drupal: >= 9.1.0, < 9.1.7 → fixed in 9.1.7

Description

Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.

Related

Alias · CVE (1)

  • CVE-2020-13672 Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References