GitHub Advisoryadvisory · Maven

GHSA-3m3f-2323-64m7 Incorrect permission checks in Jenkins Config File Provider Plugin allow enumerating credentials IDs

MEDIUM Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-21643
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:config-file-provider
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-863
Reviewed
2022-12-13

Affected packages

• Maven org.jenkins-ci.plugins:config-file-provider: < 3.7.1 → fixed in 3.7.1

Description

Jenkins Config File Provider Plugin 3.7.0 and earlier does not correctly perform permission checks in several HTTP endpoints. This allows attackers with global Job/Configure permission to enumerate system-scoped credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of system-scoped credentials IDs in Jenkins Config File Provider Plugin 3.7.1 requires Overall/Administer permission.

Related

Alias · CVE (1)

  • CVE-2021-21643 Jenkins Config File Provider Plugin 3.7.0 and earlier does not correctly perform permission checks in several HTTP endpoints, allowing… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References