GitHub Advisoryadvisory · PyPI
GHSA-3m3h-v9hv-9j4h Cross-site Scripting in django-wiki
MEDIUM
Official page ↗
- Aliases
- CVE-2021-25986
- Ecosystem
- PyPI
- Packages
- wiki
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-11-24
Affected packages
• PyPI wiki: >= 0.0.20, < 0.7.9 → fixed in 0.7.9
Description
In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.
Related
Alias · CVE (1)
- CVE-2021-25986 In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-25986 advisory
- https://github.com/django-wiki/django-wiki/pull/1148 web
- https://github.com/django-wiki/django-wiki/commit/9eaccc7519e4206a4d2f22640882f0737b2da9c5 web
- https://github.com/django-wiki/django-wiki package
- https://github.com/pypa/advisory-database/tree/main/vulns/wiki/PYSEC-2021-850.yaml web
- https://pypi.org/project/wiki web
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25986 web