GitHub Advisoryadvisory · PyPI

GHSA-3m8p-xpm6-8ww3 Ansible Arbitrary Code Execution

HIGH Published 2022-05-13 Modified 2024-09-03 Official page ↗
Aliases
CVE-2017-7466
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2024-04-22

Affected packages

• PyPI ansible: < 2.2.3.0 → fixed in 2.2.3.0

Description

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Related

Alias · CVE (1)

  • CVE-2017-7466 Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References