GitHub Advisoryadvisory · Packagist

GHSA-3m99-h3hp-w9j7 Moodle remote code execution via quiz questions

MEDIUM Published 2022-05-13 Modified 2023-08-15 Official page ↗
Aliases
CVE-2014-3545
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-94
Reviewed
2023-08-15

Affected packages

• Packagist moodle/moodle: >= 2.7.0, < 2.7.1 → fixed in 2.7.1 • Packagist moodle/moodle: >= 2.6.0, < 2.6.4 → fixed in 2.6.4 • Packagist moodle/moodle: >= 2.5.0, < 2.5.7 → fixed in 2.5.7 • Packagist moodle/moodle: >= 2.4.0, < 2.4.11 → fixed in 2.4.11

Description

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to execute arbitrary code via a calculated question in a quiz.

Related

Alias · CVE (1)

  • CVE-2014-3545 Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References