GitHub Advisoryadvisory · Maven
GHSA-3mg9-m3f6-v7fq Proxy component of Apache Pulsar subject to abuse as Denial of Service endpoint
MEDIUM
Official page ↗
- Aliases
- CVE-2022-24280
- Ecosystem
- Maven
- Packages
- org.apache.pulsar:pulsar
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-09-28
Affected packages
• Maven org.apache.pulsar:pulsar: < 2.7.5 → fixed in 2.7.5
• Maven org.apache.pulsar:pulsar: >= 2.8.0, < 2.8.3 → fixed in 2.8.3
• Maven org.apache.pulsar:pulsar: >= 2.9.0, < 2.9.2 → fixed in 2.9.2
Description
Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.
Related
Alias · CVE (1)
- CVE-2022-24280 Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness