GitHub Advisoryadvisory · Maven

GHSA-3mjp-p938-4329 Apache Tomcat vulnerable to SecurityManager bypass

HIGH Published 2022-05-13 Modified 2024-02-22 Official page ↗
Aliases
CVE-2016-6796
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Reviewed
2023-12-08

Affected packages

• Maven org.apache.tomcat:tomcat: >= 9.0.0.M1, < 9.0.0.M10 → fixed in 9.0.0.M10 • Maven org.apache.tomcat:tomcat: >= 8.5.0, < 8.5.5 → fixed in 8.5.5 • Maven org.apache.tomcat:tomcat: >= 8.0.0.RC1, < 8.0.37 → fixed in 8.0.37 • Maven org.apache.tomcat:tomcat: >= 7.0.0, < 7.0.71 → fixed in 7.0.71 • Maven org.apache.tomcat:tomcat: >= 6.0.0, < 6.0.46 → fixed in 6.0.46

Description

A malicious web application running on Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 was able to bypass a configured SecurityManager via manipulation of the configuration parameters for the JSP Servlet.

Related

Alias · CVE (1)

  • CVE-2016-6796 A malicious web application running on Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0… vulnerability

References