GitHub Advisoryadvisory · Maven
GHSA-3mwj-7vmq-w43p Stored XSS vulnerability in Jenkins Yet Another Build Visualizer Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2236
- Ecosystem
- Maven
- Packages
- com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-20
Affected packages
• Maven com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer: < 1.12 → fixed in 1.12
Description
Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission.
Yet Another Build Visualizer Plugin 1.12 escapes tooltip content.
Related
Alias · CVE (1)
- CVE-2020-2236 Jenkins Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content, resulting in a stored cross-site scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2236 advisory
- https://github.com/jenkinsci/yet-another-build-visualizer-plugin/commit/0e6db61ef66f4ed4f2e580240e364f195b00ee6e web
- https://github.com/jenkinsci/yet-another-build-visualizer-plugin package
- https://jenkins.io/security/advisory/2020-08-12/#SECURITY-1940 web
- http://www.openwall.com/lists/oss-security/2020/08/12/4 web