GitHub Advisoryadvisory · Packagist
GHSA-3p87-w3c5-27gf phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
LOW
Official page ↗
- Aliases
- CVE-2011-3591
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Low
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-15
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 3.4.0, < 3.4.5 → fixed in 3.4.5
Description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) `js/functions.js` and (2) `js/tbl_structure.js`.
Related
Alias · CVE (1)
- CVE-2011-3591 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-3591 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/bda213c58aec44925be661acb0e76c19483ea170 web
- https://bugzilla.redhat.com/show_bug.cgi?id=738681 web
- https://github.com/phpmyadmin/composer package
- http://www.openwall.com/lists/oss-security/2011/09/30/8 web
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-14.php web