GitHub Advisoryadvisory · Maven
GHSA-3pv3-jj4h-p528 Sandbox bypass vulnerability in Jenkins Script Security Plugin
CRITICAL
Official page ↗
- Aliases
- CVE-2019-1003040
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:script-security
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-470
- Reviewed
- 2022-06-01
Affected packages
• Maven org.jenkins-ci.plugins:script-security: < 1.56 → fixed in 1.56
Description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.
Related
Alias · CVE (1)
- CVE-2019-1003040 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows attackers to invoke arbitrary constructors in… vulnerability
Weakness · CWE (1)
- CWE-470 Use of Externally-Controlled Input to Select Classes or Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-1003040 advisory
- https://github.com/jenkinsci/script-security-plugin/commit/8424ad90547e37a2bd3b6a3a7da48eb1af9cd0ee web
- https://access.redhat.com/errata/RHSA-2019:1423 web
- https://github.com/jenkinsci/script-security-plugin package
- https://jenkins.io/security/advisory/2019-03-25/#SECURITY-1353 web
- http://www.openwall.com/lists/oss-security/2019/03/28/2 web
- http://www.securityfocus.com/bid/107628 web