GitHub Advisoryadvisory · npm
GHSA-3pxp-6963-46r9 Command Injection in pdfinfojs
CRITICAL
Official page ↗
- Aliases
- CVE-2018-3746
- Ecosystem
- npm
- Packages
- pdfinfojs
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-78
- Reviewed
- 2020-06-16
Affected packages
• npm pdfinfojs: < 0.4.1 → fixed in 0.4.1
Description
Versions of `pdfinfojs` before 0.4.1 are vulnerable to command injection. This is exploitable if an attacker can control the filename parameter that is passed into the `pdfinfojs` constructor.
Recommendation
Update to version 0.4.1 or later.
Related
Alias · CVE (1)
- CVE-2018-3746 The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on… vulnerability