GitHub Advisoryadvisory · npm

GHSA-3q32-j57w-q4w7 Path Traversal in total.js

HIGH Published 2019-02-20 Modified 2021-08-31 Official page ↗
Aliases
CVE-2019-8903
Ecosystem
npm
Packages
total.js
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-22
Reviewed
2020-06-16

Affected packages

• npm total.js: < 3.2.3 → fixed in 3.2.3

Description

Affected versions of `total.js` are vulnerable to Path Traversal. Due to insufficient input sanitization in URLs, attackers can access server files outside the `/public` folder by using relative paths. The files served are limited to these file types: `flac`, `jpg`, `jpeg`, `png`, `gif`, `ico`, `js`, `css`, `txt`, `xml`, `woff`, `woff2`, `otf`, `ttf`, `eot`, `svg`, `zip`, `rar`, `pdf`, `docx`, `xlsx`, `doc`, `xls`, `html`, `htm`, `appcache`, `manifest`, `map`, `ogv`, `ogg`, `mp4`, `mp3`, `webp`, `webm`, `swf`, `package`, `json`, `md`, `m4v`, `jsx`, `heif`, `heic`. Recommendation • If you are using version 2.1.x, upgrade to 2.1.1 or later. • If you are using version 2.2.x, upgrade to 2.2.1 or later. • If you are using version 2.3.x, upgrade to 2.3.1 or later. • If you are using version 2.4.x, upgrade to 2.4.1 or later. • If you are using version 2.5.x, upgrade to 2.5.1 or later. • If you are using version 2.6.x, upgrade to 2.6.3 or later. • If you are using version 2.7.x, upgrade to 2.7.1 or later. • If you are using version 2.8.x, upgrade to 2.8.1 or later. • If you are using version 2.9.x, upgrade to 2.9.5 or later. • If you are using version 3.0.x, upgrade to 3.0.1 or later. • If you are using version 3.1.x, upgrade to 3.1.1 or later. • If you are using version 3.2.x, upgrade to 3.2.4 or later.

Related

Alias · CVE (1)

  • CVE-2019-8903 index.js in Total.js Platform before 3.2.3 allows path traversal. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References