GitHub Advisoryadvisory · npm
GHSA-3q42-xmxv-9vfr OpenClaw: Gateway operator.write Can Reach Admin-Class Talk Voice Config Persistence via chat.send
MEDIUM
Official page ↗
- Aliases
- CVE-2026-41379
- Ecosystem
- npm
- Packages
- openclaw
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-269
- Reviewed
- 2026-04-07
Affected packages
• npm openclaw: < 2026.3.28 → fixed in 2026.3.28
Description
Summary
Gateway operator.write Can Reach Admin-Class Talk Voice Config Persistence via chat.send
Current Maintainer Triage
• Status: narrow
• Normalized severity: medium
• Assessment: Real shipped operator.write to admin-class Talk Voice config persistence bug, but it is the same narrow authenticated persistence class and should be normalized below high.
Affected Packages / Versions
• Package: `openclaw` (npm)
• Latest published npm version: `2026.3.31`
• Vulnerable version range: `= 2026.3.28`
• First stable tag containing the fix: `v2026.3.28`
Fix Commit(s)
• `e34694733fc64931ed4a543c73d84ad3435d5df1` — 2026-03-25T19:55:26Z
Release Process Note
• The fix is already present in released version `2026.3.28`.
• This draft looks ready for final maintainer disposition or publication, not additional code-fix work.
Thanks @zpbrent for reporting.
Related
Alias · CVE (1)
- CVE-2026-41379 OpenClaw before 2026.3.28 contains a privilege escalation vulnerability allowing authenticated operators with write permissions to access… vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness