GitHub Advisoryadvisory · RubyGems

GHSA-3qc2-v3hp-6cv8 sidekiq Denial of Service vulnerability

MEDIUM Published 2023-09-14 Modified 2023-10-05 Official page ↗
Aliases
CVE-2023-26141
Ecosystem
RubyGems
Packages
sidekiq
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
Weaknesses
CWE-345, CWE-400
Reviewed
2023-09-14

Affected packages

• RubyGems sidekiq: >= 7.0.0, < 7.1.3 → fixed in 7.1.3 • RubyGems sidekiq: < 6.5.10 → fixed in 6.5.10

Description

Versions of the package sidekiq before 7.1.3 and 6.5.10 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.

Related

Alias · CVE (1)

  • CVE-2023-26141 Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the… vulnerability

Weakness · CWE (2)

  • CWE-345 Insufficient Verification of Data Authenticity weakness
  • CWE-400 Uncontrolled Resource Consumption weakness

References