GitHub Advisoryadvisory · Packagist
GHSA-3qpq-r242-jqj7 phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()
HIGH
Official page ↗
- Aliases
- CVE-2026-44167
- Ecosystem
- Packagist
- Packages
- phpseclib/phpseclib
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2026-05-05
Affected packages
• Packagist phpseclib/phpseclib: >= 0.1.1, < 1.0.29 → fixed in 1.0.29
• Packagist phpseclib/phpseclib: >= 2.0.0, < 2.0.54 → fixed in 2.0.54
• Packagist phpseclib/phpseclib: >= 3.0.0, < 3.0.52 → fixed in 3.0.52
Description
Impact
Anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc)
Patches
https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc
Workarounds
No.
References
https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc
Related
Alias · CVE (1)
- CVE-2026-44167 phpseclib is a PHP secure communications library. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness