GitHub Advisoryadvisory · npm

GHSA-3qpv-xf3v-mm45 OpenClaw: Workspace `.env` can override the bundled hooks root and load attacker hook code

HIGH Published 2026-04-02 Modified 2026-05-06 Official page ↗
Aliases
CVE-2026-41336
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-15, CWE-829
Reviewed
2026-04-02

Affected packages

• npm openclaw: < 2026.3.31 → fixed in 2026.3.31

Description

Summary Workspace `.env` can override the bundled hooks root and load attacker hook code Current Maintainer Triage • Status: open • Normalized severity: high • Assessment: v2026.3.28 still lets workspace .env override OPENCLAW_BUNDLED_HOOKS_DIR, which can replace trusted default-on bundled hooks from an untrusted workspace. Affected Packages / Versions • Package: `openclaw` (npm) • Latest published npm version: `2026.3.31` • Vulnerable version range: `= 2026.3.31` • First stable tag containing the fix: `v2026.3.31` Fix Commit(s) • `330a9f98cb29c79b1c16a2117e03d6276a0d6289` — 2026-03-31T19:25:12+09:00 OpenClaw thanks @nexrin for reporting.

Related

Alias · CVE (1)

  • CVE-2026-41336 OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_HOOKS_DIR environment variable, enabling loading of… vulnerability

Weakness · CWE (2)

  • CWE-15 External Control of System or Configuration Setting weakness
  • CWE-829 Inclusion of Functionality from Untrusted Control Sphere weakness

References