GitHub Advisoryadvisory · npm
GHSA-3rpr-mg43-xhq4 auth0-js Privilege Escalation Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-17068
- Ecosystem
- npm
- Packages
- auth0-js
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2020-06-16
Affected packages
• npm auth0-js: < 8.12.0 → fixed in 8.12.0
Description
A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with `auth0.popup.callback()`.
Related
Alias · CVE (1)
- CVE-2017-17068 A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness