GitHub Advisoryadvisory · PyPI

GHSA-3rw2-wfc8-wmj5 Fides Webserver Vulnerable to SVG Bomb File Uploads

LOW Published 2023-07-18 Modified 2023-07-18 Official page ↗
Aliases
CVE-2023-37481
Ecosystem
PyPI
Packages
ethyca-fides
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2023-07-18

Affected packages

• PyPI ethyca-fides: >= 2.11.0, < 2.16.0 → fixed in 2.16.0

Description

Impact The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. Patches The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There is no known workaround to remediate this vulnerability without upgrading.

Related

Alias · CVE (1)

  • CVE-2023-37481 Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References