GitHub Advisoryadvisory · Packagist

GHSA-3vmm-7h4j-69rm TYPO3 vulnerable to Weak Authentication in Session Handling

MEDIUM Published 2023-11-14 Modified 2023-12-15 Official page ↗
Aliases
CVE-2023-47127
Ecosystem
Packagist
Packages
typo3/cms-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-287, CWE-302
Reviewed
2023-11-14

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.55 → fixed in 8.7.55 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.44 → fixed in 9.5.44 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.41 → fixed in 10.4.41 • Packagist typo3/cms-core: >= 11.0.0, < 11.5.33 → fixed in 11.5.33 • Packagist typo3/cms-core: >= 12.0.0, < 12.4.8 → fixed in 12.4.8

Description

> ### CVSS: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N/E:X/RL:O/RC:C` (4.0) Problem Given that there are at least two different sites in the same TYPO3 installation - for instance _first.example.org_ and _second.example.com_ - then a session cookie generated for the first site can be reused on the second site without requiring additional authentication. This vulnerability primarily affects the frontend of the website. It's important to note that exploiting this vulnerability requires a valid user account. Solution Update to TYPO3 versions 8.7.55 ELTS, 9.5.44 ELTS, 10.4.41 ELTS, 11.5.33, 12.4.8 that fix the problem described above. Credits Thanks to Rémy Daniel who reported this issue, and to TYPO3 core & security team member Benjamin Franzke who fixed the issue. References • TYPO3-CORE-SA-2023-006

Related

Alias · CVE (1)

  • CVE-2023-47127 TYPO3 is an open source PHP based web content management system released under the GNU GPL. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-302 Authentication Bypass by Assumed-Immutable Data weakness

References