GitHub Advisoryadvisory · Maven
GHSA-3vvc-v8c2-43r7 Apache Kylin has Insufficiently Protected Credentials
HIGH
Official page ↗
- Aliases
- CVE-2023-29055
- Ecosystem
- Maven
- Packages
- org.apache.kylin:kylin-core-common
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2024-01-29
Affected packages
• Maven org.apache.kylin:kylin-core-common: >= 2.0.0, < 4.0.4 → fixed in 4.0.4
Description
In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials.
To avoid this threat, users are recommended to
• Always turn on HTTPS so that network payload is encrypted.
• Avoid putting credentials in kylin.properties, or at least not in plain text.
• Use network firewalls to protect the serverside such that it is not accessible to external attackers.
• Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.
Related
Alias · CVE (1)
- CVE-2023-29055 In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-29055 advisory
- https://github.com/apache/kylin/commit/b60d5ae694dffc2281bfe0ef464eada0b3a9b774 web
- https://github.com/apache/kylin package
- https://lists.apache.org/thread/o1bvyv9wnfkx7dxpfjlor20nykgsoh6r web
- http://www.openwall.com/lists/oss-security/2024/01/29/1 web