GitHub Advisoryadvisory · Packagist

GHSA-3w4h-r27h-4r2w TYPO3 Image Processing susceptible to Code Execution

HIGH Published 2022-05-24 Modified 2024-02-20 Official page ↗
Aliases
CVE-2019-11832
Ecosystem
Packagist
Packages
typo3/cms-core, typo3/cms
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-94
Reviewed
2024-02-20

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.25 → fixed in 8.7.25 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.6 → fixed in 9.5.6 • Packagist typo3/cms: >= 8.0.0, < 8.7.25 → fixed in 8.7.25 • Packagist typo3/cms: >= 9.0.0, < 9.5.6 → fixed in 9.5.6

Description

TYPO3 8.x before 8.7.25 and 9.x before 9.5.6 is susceptible to remote code execution because it does not properly configure the applications used for image processing, as demonstrated by ImageMagick or GraphicsMagick. For a successful exploit, the GhostScript binary `gs` must be available on the server system.

Related

Alias · CVE (1)

  • CVE-2019-11832 TYPO3 8.x before 8.7.25 and 9.x before 9.5.6 allows remote code execution because it does not properly configure the applications used for… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-94 Improper Control of Generation of Code weakness

References