GitHub Advisoryadvisory · Go
GHSA-3wqc-mwfx-672p Traefik affected by Go oauth2/jws Improper Validation of Syntactic Correctness of Input vulnerability
HIGH
Official page ↗
- Ecosystem
- Go
- Packages
- github.com/traefik/traefik/v3, github.com/traefik/traefik/v2
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1286
- Reviewed
- 2025-04-18
Affected packages
• Go github.com/traefik/traefik/v3: < 3.3.6 → fixed in 3.3.6
• Go github.com/traefik/traefik/v2: < 2.11.24 → fixed in 2.11.24
• Go github.com/traefik/traefik/v3: >= 3.4.0-rc1, < 3.4.0-rc2 → fixed in 3.4.0-rc2
Description
Summary
We have encountered a security vulnerability being reported by our scanners for Traefik 2.11.22.
• https://security.snyk.io/vuln/SNYK-CHAINGUARDLATEST-TRAEFIK33-9403297
Details
It seems to target oauth2/jws library.
PoC
No steps to replicate this vulnerability
Impact
We have a strict control on security and we always try to stay up-to-date with the fixes received for third-party solutions.
Patches
• https://github.com/traefik/traefik/releases/tag/v2.11.24
• https://github.com/traefik/traefik/releases/tag/v3.3.6
• https://github.com/traefik/traefik/releases/tag/v3.4.0-rc2
Related
Weakness · CWE (1)
- CWE-1286 Improper Validation of Syntactic Correctness of Input weakness
References
- https://github.com/traefik/traefik/security/advisories/GHSA-3wqc-mwfx-672p web
- https://github.com/traefik/traefik package
- https://github.com/traefik/traefik/releases/tag/v2.11.24 web
- https://github.com/traefik/traefik/releases/tag/v3.3.6 web
- https://github.com/traefik/traefik/releases/tag/v3.4.0-rc2 web
- https://security.snyk.io/vuln/SNYK-CHAINGUARDLATEST-TRAEFIK33-9403297 web