GitHub Advisoryadvisory · PyPI

GHSA-3wxx-q3gv-pvvv LlamaIndex vulnerable to DoS attack through uncontrolled recursive JSON parsing

MEDIUM Published 2025-07-07 Modified 2025-07-08 Official page ↗
Aliases
CVE-2025-5472
Ecosystem
PyPI
Packages
llama-index-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weaknesses
CWE-674
Reviewed
2025-07-08

Affected packages

• PyPI llama-index-core: < 0.12.38 → fixed in 0.12.38

Description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Related

Alias · CVE (1)

  • CVE-2025-5472 The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References