GitHub Advisoryadvisory · Go

GHSA-3x39-62h4-f8j6 Mattermost fails to properly validate OAuth state tokens during OpenID Connect authentication

CRITICAL Published 2025-11-27 Modified 2025-12-17 Official page ↗
Aliases
CVE-2025-12419
Ecosystem
Go
Packages
github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-287, CWE-303
Reviewed
2025-12-01

Affected packages

• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20251028000919-d3ed703dc833 → fixed in 8.0.0-20251028000919-d3ed703dc833 • Go github.com/mattermost/mattermost-server: >= 10.12.0, < 10.12.2 → fixed in 10.12.2 • Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.5 → fixed in 10.11.5 • Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.13 → fixed in 10.5.13 • Go github.com/mattermost/mattermost-server: >= 11.0.0, < 11.0.4 → fixed in 11.0.4

Description

Mattermost versions 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12, 11.0.x <= 11.0.3 fail to properly validate OAuth state tokens during OpenID Connect authentication which allows an authenticated attacker with team creation privileges to take over a user account via manipulation of authentication data during the OAuth completion flow. This requires email verification to be disabled (default: disabled), OAuth/OpenID Connect to be enabled, and the attacker to control two users in the SSO system with one of them never having logged into Mattermost.

Related

Alias · CVE (1)

  • CVE-2025-12419 Mattermost versions 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12, 11.0.x <= 11.0.3 fail to properly validate OAuth state… vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-303 Incorrect Implementation of Authentication Algorithm weakness

References