GitHub Advisoryadvisory · Packagist

GHSA-3x9x-vhqj-cv27 Magento XML Injection vulnerability in the Widgets Update Layout

HIGH Published 2022-05-24 Modified 2025-11-06 Official page ↗
Aliases
CVE-2021-36022
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74, CWE-78, CWE-91
Reviewed
2025-11-06

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1 • Packagist magento/community-edition: 2.3.7 (no fix yet) • Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2 • Packagist magento/community-edition: 2.4.2 (no fix yet)

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Update Layout. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.

Related

Alias · CVE (1)

  • CVE-2021-36022 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection… vulnerability

Weakness · CWE (3)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
  • CWE-91 XML Injection weakness

References