GitHub Advisoryadvisory · RubyGems
GHSA-3xg8-cc8f-9wv2 Unsanitized input leading to code injection in Dalli
LOW
Official page ↗
- Aliases
- CVE-2022-4064
- Ecosystem
- RubyGems
- Packages
- dalli
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-74
- Reviewed
- 2022-11-21
Affected packages
• RubyGems dalli: < 3.2.3 → fixed in 3.2.3
Description
A vulnerability was found in Dalli. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation leads to injection. The exploit has been disclosed to the public and may be used. The name of the patch is 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to apply a patch to fix this issue.
Related
Alias · CVE (1)
- CVE-2022-4064 A vulnerability was found in Dalli up to 3.2.2. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-4064 advisory
- https://github.com/petergoldstein/dalli/issues/932 web
- https://github.com/petergoldstein/dalli/pull/933 web
- https://github.com/petergoldstein/dalli/commit/48d594dae55934476fec61789e7a7c3700e0f50d web
- https://github.com/petergoldstein/dalli package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/dalli/CVE-2022-4064.yml web
- https://vuldb.com/?id.214026 web