GitHub Advisoryadvisory · Packagist
GHSA-3xh5-5v5v-mfgm Moodle reflected Cross-site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2019-14884
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.7.0, < 3.7.3 → fixed in 3.7.3
• Packagist moodle/moodle: >= 3.6.0, < 3.6.7 → fixed in 3.6.7
• Packagist moodle/moodle: >= 3.5.0, < 3.5.9 → fixed in 3.5.9
Description
A vulnerability was found in Moodle 3.7 before 3.7.3, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.
Related
Alias · CVE (1)
- CVE-2019-14884 A vulnerability was found in Moodle 3.7 before 3.73, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness