GitHub Advisoryadvisory · PyPI

GHSA-3xvg-x47j-x75w Ansible Improper Input Validation vulnerability

HIGH Published 2022-05-13 Modified 2024-09-09 Official page ↗
Aliases
CVE-2018-10874
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-426
Reviewed
2023-02-08

Affected packages

• PyPI ansible: < 2.4.6.0 → fixed in 2.4.6.0 • PyPI ansible: >= 2.5, < 2.5.6 → fixed in 2.5.6 • PyPI ansible: >= 2.6, < 2.6.1 → fixed in 2.6.1

Description

In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under attacker's control, allowing to run arbitrary code as a result.

Related

Alias · CVE (1)

  • CVE-2018-10874 In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-426 Untrusted Search Path weakness

References