GitHub Advisoryadvisory · PyPI

GHSA-3xxv-p78r-4fc6 Cross-site Scripting in Apache Airflow

MEDIUM Published 2021-06-18 Modified 2024-09-12 Official page ↗
Aliases
CVE-2021-28359
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-05-20

Affected packages

• PyPI apache-airflow: < 1.10.15 → fixed in 1.10.15 • PyPI apache-airflow: >= 2.0.0a1, < 2.0.2 → fixed in 2.0.2

Description

The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to the latest available PATCH releases of the installed MINOR versions, example update to Python 3.6.13 if you are on Python 3.6. (Those contain the fix for CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336).

Related

Alias · CVE (1)

  • CVE-2021-28359 The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References