GitHub Advisoryadvisory · Maven

GHSA-429q-mrc4-38fr Apache Camel Deserializes Untrusted Data in its LevelDB Component

HIGH Published 2026-02-23 Modified 2026-02-25 Official page ↗
Aliases
CVE-2026-25747
Ecosystem
Maven
Packages
org.apache.camel:camel-leveldb
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-502
Reviewed
2026-02-25

Affected packages

• Maven org.apache.camel:camel-leveldb: >= 3.0.0, < 4.10.9 → fixed in 4.10.9 • Maven org.apache.camel:camel-leveldb: >= 4.11.0, < 4.14.5 → fixed in 4.14.5 • Maven org.apache.camel:camel-leveldb: >= 4.15.0, < 4.18.0 → fixed in 4.18.0

Description

Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5

Related

Alias · CVE (1)

  • CVE-2026-25747 Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References