GitHub Advisoryadvisory · PyPI
GHSA-42fp-4hm3-j8r7 Moderate severity vulnerability that affects moin
MEDIUM
Official page ↗
- Aliases
- CVE-2017-5934
- Ecosystem
- PyPI
- Packages
- moin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• PyPI moin: < 1.9.10 → fixed in 1.9.10
Description
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2017-5934 Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-5934 advisory
- https://github.com/moinwiki/moin-1.9/commit/70955a8eae091cc88fd9a6e510177e70289ec024 web
- https://github.com/moinwiki/moin-1.9 package
- https://github.com/pypa/advisory-database/tree/main/vulns/moin/PYSEC-2018-47.yaml web
- https://lists.debian.org/debian-lts-announce/2018/10/msg00007.html web
- https://usn.ubuntu.com/3794-1 web
- https://www.debian.org/security/2018/dsa-4318 web
- http://lists.opensuse.org/opensuse-security-announce/2018-10/msg00024.html web
- http://moinmo.in/SecurityFixes web