GitHub Advisoryadvisory · PyPI

GHSA-42h5-h8qh-vv9v MLflow allows an unauthenticated remote attacker to read arbitrary files from the server's filesystem

HIGH Published 2026-05-11 Modified 2026-05-18 Official page ↗
Aliases
CVE-2026-2614
Ecosystem
PyPI
Packages
mlflow
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-22
Reviewed
2026-05-18

Affected packages

• PyPI mlflow: < 3.10.0 → fixed in 3.10.0

Description

A vulnerability in the `_create_model_version()` handler of `mlflow/server/handlers.py` in mlflow/mlflow versions 3.9.0 and earlier allows an unauthenticated remote attacker to read arbitrary files from the server's filesystem. The issue arises when a `CreateModelVersion` request includes the tag `mlflow.prompt.is_prompt`, which bypasses source path validation. This enables an attacker to store an arbitrary local filesystem path as the model version source. The `get_model_version_artifact_handler()` function later uses this source to serve files without verifying the model version's prompt status, leading to a complete confidentiality compromise. This issue is fixed in version 3.10.0.

Related

Alias · CVE (1)

  • CVE-2026-2614 A vulnerability in the `_create_model_version()` handler of `mlflow/server/handlers.py` in mlflow/mlflow versions 3.9.0 and earlier allows… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References