GitHub Advisoryadvisory · PyPI
GHSA-42q4-9xf9-f67x Apache Superset allowed for database connections password leak for authenticated users
HIGH
Official page ↗
- Aliases
- CVE-2021-41972
- Ecosystem
- PyPI
- Packages
- apache-superset
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2022-06-21
Affected packages
• PyPI apache-superset: < 1.3.2 → fixed in 1.3.2
Description
Apache Superset up to and including 1.3.1 allowed for database connections password leak for authenticated users. This information could be accessed in a non-trivial way.
Related
Alias · CVE (1)
- CVE-2021-41972 Apache Superset up to and including 1.3.1 allowed for database connections password leak for authenticated users. vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-41972 advisory
- https://github.com/advisories/GHSA-42q4-9xf9-f67x advisory
- https://github.com/apache/superset web
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-superset/PYSEC-2021-434.yaml web
- https://lists.apache.org/thread/xpdl2r538o695o7r9gd9qrwqb17bdd3v web
- https://seclists.org/oss-sec/2021/q4/106 web