GitHub Advisoryadvisory · Packagist
GHSA-438m-6mhw-hq5w Mautic vulnerable to secret data extraction via elfinder
MEDIUM
Official page ↗
- Aliases
- CVE-2025-9822
- Ecosystem
- Packagist
- Packages
- mautic/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-283
- Reviewed
- 2025-09-03
Affected packages
• Packagist mautic/core: >= 4.4.0, < 4.4.17 → fixed in 4.4.17
• Packagist mautic/core: >= 5.0.0-alpha, < 5.2.8 → fixed in 5.2.8
• Packagist mautic/core: >= 6.0.0-alpha, < 6.0.5 → fixed in 6.0.5
Description
Summary
_A user with administrator rights can change the configuration of the mautic application and extract secrets that are not normally available._
Impact
_An administrator who usually does not have access to certain parameters, such as database credentials, can disclose them._
Related
Alias · CVE (1)
- CVE-2025-9822 SummaryA user with administrator rights can change the configuration of the mautic application and extract secrets that are not normally… vulnerability
Weakness · CWE (1)
- CWE-283 Unverified Ownership weakness
References
- https://github.com/mautic/mautic/security/advisories/GHSA-438m-6mhw-hq5w web
- https://nvd.nist.gov/vuln/detail/CVE-2025-9822 advisory
- https://github.com/mautic/mautic/commit/882c2c5be646e36f7b91e7c4b24f71aafa617cd5 web
- https://github.com/mautic/mautic/commit/a310b1933de7cfefec03382a4d8c0d9dbbaa0600 web
- https://github.com/mautic/mautic package